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INTRO 
Drupal has become a leading platform for managing web-based content. It can be used to 

deliver your corporate website, as a support and FAQ portal, or virtually anything else you can 

dream of. More and more companies, including many large enterprises in the Fortune 500, are 

using Drupal to present and manage their web-based content. 

But what if you’re a company who needs to serve audiences who speak different languages? 

Some popular Drupal modules can help you serve content in the language preferred by your 

site visitors. Unfortunately, Drupal does not offer any way to efficiently manage the process of 

translation for even a small amount of content. Drupal customers often have to copy and paste 

their source content into a document they send to their translation vendors, and then copy and 

paste all the translated materials back into Drupal. The sheer time and error-prone nature of this 

makes translating Drupal content painful at best, impossible at worst. 

Cloudwords, using its best-in-industry integration knowledge and API, has made translating 

Drupal easier.  

HOW IT WORKS 
Through the Cloudwords for Drupal module, you will: 

 Pick what Drupal pages, nodes, menu items, etc. you want to send out for translation 

 Sync that content to Cloudwords and route it to the translation vendor(s) of your choice 

 Sync the translated content back into Drupal once your translation vendor has delivered 

the translated content into Cloudwords 

 Let our module automatically detect new and outdated translations that require your 

attention 

Since the Cloudwords for Drupal module manages your translation process via Cloudwords, you 

enjoy all the standard Cloudwords benefits:  

 Time-saving project management and workflow 

 Vendor management 

 Cost-saving benefits of centralized Translation Memory, and more.  

Cloudwords also sends your Drupal content to translation vendors via XLIFF, a translation 

industry XML standard that helps simplify the process to drive down translation costs and time. 
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BEFORE YOU INSTALL 
Please go through the checklists below to make sure you are ready to install the Cloudwords for 

Drupal module.  

In Cloudwords 

Cloudwords offers a sandbox test environment for trying out the Drupal integration before 

switching it on to your production account. This allows you to try out the module without having 

to pay for translations. 

A) Testing with Cloudwords Sandbox Account 

□ To create a Cloudwords sandbox account, go to http://developer.cloudwords.com and 

sign up for free. You will receive a welcome email with instructions on how to access 

your new sandbox account.  

 

□ Generate an API key: 

1. Log into your Cloudwords Sandbox account. 

2. In the upper right corner, click Settings > My Account. 

3. Click the API tab. 

4. Click the Generate Access Key button. Take note of this. 

 

B) Testing with Cloudwords Production Account 

□ If you do not already have an existing Cloudwords production account, sign up for one at 

http://www.cloudwords.com/editions/start-today/. You will receive a welcome email with 

instructions on how to access your new production account. 

 

□ Generate an API key: 

1. Log into your Cloudwords Production account. 

2. In the upper right corner, click Settings > My Account. 

3. Click the API tab. 

4. Click the Generate Access Key button. Take note of this. 

 

In Drupal 

□ Confirm you are using Drupal version 7.x. The Cloudwords module for Drupal does not 

work with previous versions of Drupal (6 or earlier).  

 

□ Confirm the following modules are installed in Drupal: 

 

http://developer.cloudwords.com/
http://www.cloudwords.com/editions/start-today/
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o Entity API 

o Chaos Tool Suite 

o Views 

o Views Bulk Operations 

 

□ Optionally, install the Internationalization module. If you choose to enable 

Internationalization, be sure to enable the corresponding Cloudwords i18n components 

and install the dependent variable module.  
□ Install the PHP cURL library. (For example, on Ubuntu, the command is sudo apt-get 

install php5-curl.) 

□ Disable the Entity Translation module. 

□ Enable the View UI module (installed as part of Views, listed above). 
 
  

Please verify that you have set the private upload directory for your Drupal instance. In Drupal, 

click Configuration. In the Media section, click File System, and ensure that the Private file 

system path field has a valid value.   

□ To keep up-to-date on any issues and fixes related to the module, create a user 

account on Drupal.org (if you haven't done so already) and then subscribe to the feed.  

PHP 5.2  

 

Please, make sure the following setting in your php.ini file is set to off: 

php_flag output_buffering 

INSTALLING THE CLOUDWORDS DRUPAL MODULE 
 

There are two ways to install the Cloudwords Drupal module: upload module files to a Drupal 7 

site: 

 Option 1:  Through the Drupal user interface—This may not work on some servers, 

though it is a more user-friendly choice. 

 Option 2:  Manually on the server 

OPTION ONE: Install the Cloudwords Module using the Drupal user interface  

1. Go to https://drupal.org/project/cloudwords 

2. Scroll to the bottom of the page and download the latest stable release (Highlighted in 

green). 

https://drupal.org/project/entity
https://drupal.org/project/ctools
https://drupal.org/project/views
https://drupal.org/project/views_bulk_operations
https://drupal.org/project/i18n
https://drupal.org/project/variable
http://php.net/manual/en/book.curl.php
https://drupal.org/project/entity_translation
http://drupal.org/user/register
http://drupal.org/user/register
https://drupal.org/project/cloudwords
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3. Login into Drupal with Administrator rights. 

4. Navigate to the Modules > List (tab), and click the Install New Module link. (Note: You 

must have the Update Manager module enabled to see this link.)  

 

5. You will be prompted to either enter a URL or upload a .tar.gz or .zip file that you have 

saved to your local computer: 
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6. Right-click in the Install from a URL box and paste the URL you grabbed in step 2.  

7. Click the Install button. The Update Manager copies the files into your sites/all/modules 

folder. 

NOTE:   If your site asks for your FTP username and password, it is referring to the 

username and password to access your site, not drupal.org 

8. On the next screen, click the Enable Newly Added Modules link.  

9. Enable the Cloudwords module by checking the Cloudwords checkboxes and click Save 

Configuration. 

10. In the main menu, click Configuration, then Web Services, then Cloudwords. 

11. In the API Authorization Token field, copy the API key you generated in Cloudwords  

(see page 4). 

12. Click Save Configuration. 

13. Proceed to the next secion.  

 

OPTION TWO: Install the Cloudwords Module manually on the server 

1. Go to https://drupal.org/project/cloudwords. 

2. At the bottom of the page, download the .tar or .zip file to your local computer. 

3. Extract the files. You should see a list of files extracted into a folder. 

4. Transfer the files with SFTP or FTP to the desired modules folder in your Drupal 

installation (or if you are using version control, add and commit them to your code 

repository). Contributed modules belong in sites/all/modules. (If you are running a multi-

site installation of Drupal, use sites/my.site.folder/modules for modules there that are 

specific to a particular site in your installation. Modules that will be shared between all sites 

should be placed in sites/all/modules.) 

5. Click the Enable Newly Added Modules link.  

6. Enable the Cloudwords module by checking the Cloudwords checkboxes and click Save 

Configuration. 

7. In the main menu, click Configuration, then Web Services, then Cloudwords. 

8. In the API Authorization Token field, copy the API key you generated in Cloudwords  (see 

page 4). 

https://drupal.org/project/cloudwords
https://drupal.org/node/346385
https://drupal.org/node/346385
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9. Click Save Configuration. 

10. Proceed to the next section. 
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ENABLING MULTILINGUAL SUPPORT 
Before you can begin creating translation projects, you will to need enable multilingual support 
in the Drupal UI. If you have already done this, skip to the next section. 

To enable Multilingual Support, first open the Structure area from the Drupal toolbar. Next, 
select Content Types. 

 

 

Next, click on edit for each Content Type you wish to translate. 
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Select Publishing Options in the left-side navigation. Under the Multilingual Support section, 
select the Enable, with translation radio button and click Save content type. 
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ADDING LANGUAGES 
You will need at least two languages enabled in your Drupal instance before creating translation 
projects through Cloudwords. If you have already done this, skip to the next section. 

First, open Configuration from the Drupal toolbar and click Languages in the Regional and 
Language section. 
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Next, select Add Language to add the desired language. 
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VERIFYING THE MODULE WAS INSTALLED CORRECTLY 
Before you begin to translate content, verify that you have installed the module correctly: 

□ Browse to a page you want to translate. Click Edit. You should see a Translate tab, and a 

“Language section, as shown in the screenshot below. 

 

If you don’t, make sure the node is not set to “LANGUAGE_NEUTRAL” language.  

□ In Drupal, click Structure > Cloudwords. Confirm that you see three tabs: Create Project, 

Manage Projects, and Marked for Translation. 

 
□ In Drupal, click Structure > Cloudwords, and then the Marked for Translation tab. You 

should see  list of your content. 
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HOW TO GET YOUR CONTENT TRANSLATED 
Now that you’ve installed the module and verified it’s been installed correct, consider a couple of 

issues before jumping into your first translation project: 

 Any content that you want to be translated should be set to a language (like “English”), not 

“LANGUAGE_NEUTRAL”. 

 The contents of a “project” goes to a single vendor.  So if you plan to use one vendor for 

your French and German projects, and a different vendor for your Portuguese project, be 

sure to create two separate projects for that same piece of source content.  

 If you have reference material you want to add to the project, compress it into a .zip file and 

have it ready before you create your project. 

 

1. Log into your Drupal account. 

2. Go to Structure > Cloudwords. 

3. On the Create Project tab, use the filters to find the content you want to translate. For 

example, if you use the Type filter to select Content, the Content Type filter appears to 

further refine the list of pages you see below.

 
4. Select the checkboxes next to the items you want to translate.  

5. When you are done marking items to translate, click the Create Project button. 

6. Enter a Name for the translation project. 

7. If you have other reference material you want the vendor to consider, click the Choose 

File button to find the reference files that you have in a compressed .zip file. 

8. Look at the list of items to confirm these are the pieces you want translated. If you want 

to add items, click the Back button, mark additional items, and click Create Project.  
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9. Now click Submit. 

 
10. Click the Please finish creating your project in Cloudwords link.  

This opens the Cloudwords application (website) in a separate browser window.  

11. If necessary, log into Cloudwords.  

12. In the left column, use the dropdown to select an Intended Use for the project. 

13. In the right column, use the date controls to indicate when you want bids back from 

vendors, and when you need the translation delivered for you to review. 

14. DO NOT TOUCH the source or target language controls. 

15. Click Next. 

16. DO NOT ADD OR REPLACE source material files. You will see that there is already a 

.zip file with the contents from Drupal already attached to your project – Cloudwords 

extracted those contents from your Drupal, generating the .xliff files included in that zip. 

17. Click Next. 

18. On the Workflow and Followers page, click Next. 

19. Select the vendors and/or the “let Cloudwords choose other vendors for me” option. 

20. Click Finish and Request Bids. Vendors will receive your bid request, and will have the 

opportunity to submit their quote for your project.  

21. You will be notified by email when vendors have entered bids into Cloudwords. The 

email contains a link to get back into Cloudwords and select a winning vendor for your 

project. 

22. When the vendor delivers translated content into Cloudwords, you’ll receive an email 

notification that the translated content is ready to review. 

23. At that time, go into Drupal, and click Structure > Cloudwords.  

24. Click the Manage Projects tab. 

25. Click the project name. Click Import next to the language you want to review. 
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26. Click the language. Then click the project name. The Edit page displays. Review the 

content on the View tab, or the Edit tab. 

27. Now you can either make changes to the translated content yourself, or request that the 

vendor make changes. 

 To make changes to the translated content yourself, click the Edit tab in 

Drupal and make changes. 

 To ask the vendor to make changes, log into Cloudwords, find the project, 

click its Translations section, then click Request Revisions. 

When the vendor uploads the updated content into Cloudwords, you’ll jump 

back to step 22, above (receiving email notification about materials ready to 

review).  

28. (In Drupal) When you consider the translations for a language are final and don’t need 

any additional work, click Approve next to the project and language in the Manage 

Projects tab in Drupal. 

Note: Do not submit any Change Orders in Cloudwords. Change Orders are not supported in 

the Cloudwords Drupal integration. 
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TROUBLESHOOTING & FREQUENTLY ASKED QUESTIONS 
 

Q:   I don’t see a Translate tab when I edit a topic. What should I do?  

A:   If you don’t, make sure the node is not set to “LANGUAGE_NEUTRAL” language.  

 

Q:   How do I change the “language” setting of multiple pieces of content in one click? Do I have 

to change each piece of content in Drupal to show “English” (not “LANGUAGE_NEUTRAL”)? Or 

is there way to do this in bulk? 

A:   To do this in bulk, in Drupal, click Content. Under Show Only Items Where, change the 

Language drop-down to “LANGUAGE_NEUTRAL” and click Filter. Then, click the checkbox for 

Title in the first row of the table to select all the items. Under Update Options, the dropdown 

should read Set Language For Selected Content. Click Update. Select a Language and click 

Confirm. 

 

Q:   What if the XLF attached to the project in Cloudwords doesn’t contain any body text to 

translate? That is, the zip file contains a valid .XLF file, but there is no text to translate inside it, 

while there is text on the actual web page. 

A:   You may be using an older version of the Cloudwords Drupal Module. Please go to 

https://drupal.org/project/cloudwords and download and install the latest Recommended 

release. 

 

Q:   How is the Cloudwords Drupal module different from the Drupal Multilingual module? 

A:   You need the Drupal Multilingual module installed in order for Cloudwords Drupal to work 

correctly.  

 

Q:   What if I select Type as Content, and I don’t see the pages I want translated? 

A:   Continue to adjust the other filters until you find the pages you want to translate. 

 

  

https://drupal.org/project/cloudwords
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Q:   What if I see the page I want to translate, but not the target language I want next to it?  

A:   Navigate to the page, click Edit, and then make sure the language is set to English (or the 

source language of your site), not language_neutral.  Also, check your Drupal Regional and 

Language configuration to be sure the language you want is enabled.

LEARN MORE AND GET HELP 

Tutorial Videos 

 Introduction and Managing Multilingual Content 

 Creating and Managing a Translation Project 

Who to contact for help 

 Send us an email at support@cloudwords.com 

http://player.vimeo.com/video/61862938
http://player.vimeo.com/video/61862939
support@cloudwords.com
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